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Executive Summary
FileMaker Pro is the perfect database application to manage shipment tracking and mailing label 
creation for your business.  FileMaker Pro includes a set of easy to use business templates that you can 
easily adapt for your specific shipping management requirements.

This guide shows you how an existing FileMaker database, the Business Productivity Solution which 
is available for download from the FileMaker Web site, can be easily adapted to help you manage 
shipping for your business or workgroup.  This guide will show you how the new FileMaker Web Viewer 
feature can be added to a layout, to track shipments online directly from your database.  The built in 
layout assistant will be demonstrated, to show how easily a custom shipping label can be added to 
your database.  Finally, a third party FileMaker barcode plug-in will be demonstrated, which enables 
you to include a postal barcode on your shipping labels.

Introduction
FileMaker Pro is the perfect partner in your business for managing people, projects, assets and more. 
The same best-selling database application can be just as effective for your team to manage order 
fulfilment, package labelling and shipment tracking.

The ability for FileMaker to manage shipping has been further enhanced with the release of FileMaker 
Pro 8.5, which includes the new FileMaker Web Viewer control.  It is now possible to add a Web page 
within a FileMaker Pro 8.5 layout which can display the shipping status of a package, based on the 
contents of a shipping reference field.

FileMaker includes a built in layout assistant to help you design mailing labels for letters and packages.  
The assistant can guide you in designing a mailing label layout, using a standard Avery template or 
a custom label.  It is also possible to use a FileMaker plug-in, developed by third party developers 
and solution providers, to add an industry standard barcode to your labels, such as the USPS, PostNet 
or Royal Mail barcodes.  You may find that your postal service may be able to offer your business a 
discount, if you include postal address barcodes on your printed labels.

Top Reasons to Read this Guide
By spending a short time with this informative guide, you will learn how to:

•	 Take control of your shipping requirements with FileMaker

•	 Use FileMaker to integrate customer orders and shipping details in a single  
company wide database

•	 Provide your customers with accurate delivery times for shipments using the  
FileMaker Web Viewer control

•	 Customize the FileMaker Web Viewer control for your own preferred  shipping  
service provider 

•	 Save your staff time by printing customer mailing labels using FileMaker 

•	 Avoid address errors and negotiate reduced mailing charges by adding Barcodes  
to your mailing labels
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Before You Get Started
You will need a copy of FileMaker Pro 8.5 installed on your Macintosh or Windows computer, to try out 
all the shipping solutions presented in this guide.  If you are using a previous version of FileMaker in 
your business, you may be eligible for special upgrade pricing.  Speak to your local FileMaker office 
about this, or check the FileMaker Web site at www.filemaker.com.

The minimum system requirements for FileMaker Pro 8.5 are shown in Table 1.

Macintosh
•	 Macintosh computer with a PowerPC G3, G4, or G5 processor 
•	 Apple computers with Intel processors 
•	 256MB of RAM 
•	 CD or DVD drive and hard disk drive 
•	 Mac OS X 10.3.9 or Mac OS X 10.4 

Windows
•	 Pentium III 500MHz or higher 
•	 256MB of RAM 
•	 CD or DVD drive and hard disk drive 
•	 SVGA (800 x 600) or higher resolution video adapter and display 
•	 Windows 2000 (Service Pack 4), Windows XP (Service Pack 2) 

Table 1: FileMaker Pro 8.5 system requirements

You can also request a free 30-day trial copy of FileMaker Pro 8.5 at www.filemakertrial.com/bpk.  After 
you have submitted your details you will be redirected to a download page. You can also download the 
FileMaker Business Productivity Solution database files.  These files are fully working business database 
templates which you can either start to use immediately, or customize for your own business needs.  
The files are also a great source for design ideas which you can apply in designing your own database.  
We will be using these files to demonstrate how easily a database can be adapted for your specific 
shipping requirements.  You can also request a copy of FileMaker Pro 8.5 and the Business Productivity 
Solution files in other languages, from your regional FileMaker Web site. FileMaker International’s Web 
sites and distributors are listed at www.filemaker.com/company/intl/index.html.

Install FileMaker Pro 8.5 on your computer and expand the contents of the compressed Zip or DMG 
file that contains the Business Productivity Solution files.  Save the expanded folder to your desktop or 
another preferred location.

Adding a Web Viewer Control to your FileMaker database 
to Track Shipping

Step 1:  Adding Sample Records to the Business Productivity Solution files

Launch FileMaker Pro 8.5 on your computer and using the Open File dialog box, locate and open the 
folder called BPS_1.0, which contains the Business Productivity Solution files.  Open the file called bps_
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_Main_Menu.  This file will open the associated FileMaker files that make up the Business Productivity 
Solution.

A dialog box may appear as the file opens advising you that the date and time formats for the file 
are different to your computer’s system settings.  You can dismiss this message by clicking either the 
‘System’s Setting’, or ‘File’s Setting’ buttons.

The Business Productivity Solution Main Menu window will appear, as shown in Figure 1.

Figure 1:  The Business Productivity Solution Main Menu window

We are going to want to improve the functionality of the Sales Orders module, within the Business 
Productivity Solution, by adding a new Web Viewer control panel to track shipments online.  Before we 
do this, it would be of benefit to add some new sample or actual records to the Contacts and Inventory 
files.

Let’s start by opening the Contacts window, by clicking the Contacts button at the top of the wheel icon 
in the Main Menu.  In the Contacts window, shown in Figure 2, click the button entitled ‘New’ to add a 
record to the file, and type in contact, company and address details for the customer.  In addition to 
the mouse, you can use the Tab key to move through the fields on screen, or the Shift and Tab keys to 
return to a previous field.
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Figure 2:  The Contacts Window in the Business Productivity Solution

We want to create a new sales order for our new customer record and use the new FileMaker Web 
Viewer feature to track the order shipment.  Before we can do this, we will need to add some records to 
the Inventory file, for our goods and services that will be itemized in our sales invoices.

Click the Home button, marked with the wheel icon, to open the Main Menu window again and click 
the Inventory button.  In the Inventory window, shown in Figure 3, which will then open, click the button 
entitled ‘New’ to add a record to the file, and type in details on a product.  You can add further records 
for other products that your business provides, either now or at a later stage.
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Figure 3:  The Inventory Window in the Business Productivity Solution

Step 2:  Creating a New Sales Order Record

We now have enough information captured in the Business Productivity Solution files to create a new 
sales order.  Click the Home button to return to the Main Menu window and click the Sales Orders 
button.  In the Sales Order window, shown in Figure 4, which will then open, click the button entitled 
‘New’ to add a record to the file.

Click the arrow to the right side of the field marked Bill To, to display a drop-down list of customer 
records and click the appropriate name from the list for this sales order.  The company and address 
details for the selected customer will automatically be added to the new sales order record.  You can 
now add line items to the Sales order by clicking the field entitled Serial Number.  A drop-down list of 
products will appear to enable you to select the appropriate item.  The product name will be inserted 
into the description field automatically, using FileMaker’s lookup field option.  Add the correct quantity 
for the line item and any applicable sales tax or discount rates for the order. A total price for the order 
will be calculated and displayed.
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Figure 4:  The Sales Orders Window in the Business Productivity Solution

It is easy to adapt the Sales Order file to enable us to track order shipments online with FileMaker. 
Before we can do this, we need to carry out some minor modifications to the file.

Step 3:  Customizing the Ship Via Value List and Adding a Shipping Reference Field to the  
Sales Order File

In order to make full use of the FileMaker Web Viewer control to manage shipment tracking, we need 
to modify the value list for the Ship Via field, in the Sales Order file and add a new field called Shipping 
Reference.

Open the Sales Order Window and switch to Layout Mode, by selecting the menu option View > 
Layout Mode, clicking the Layout Mode Tab in the Status Area (marked with a set square icon), or 
selecting Layout from the Mode pop up menu at the bottom of the FileMaker document window.  
Double click on the field called Ship Via, which will open the Field/Control Setup dialog box, shown 
in Figure 5.  We want to make the value list called ‘Ship Via List’ appear as a drop-down list, when the 
Ship Via field is selected.  Before we do this, we need to modify the contents of the value list, so that it 
contains a list of possible courier companies.  With the cursor, select the option Define Value Lists as 
shown in Figure 5.
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Figure 5:  The Field/Control Setup dialog box

A Define Value Lists dialog box will now appear, with a list of value lists for the file, their source and 
values.  This is shown in Figure 6.

Figure 6:  The Define Value Lists dialog box
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Double click on the value list named Ship Via List, to open the Edit Value List dialog box, shown in 
Figure 7.  Add the names of your shipping suppliers to the list.  Click OK, three times to return to Sales 
Order Form View layout.
 

Figure 7:  The Edit Value List dialog box

We need to add a new field to record the unique tracking reference that our shipping company will 
provide us, when delivering a customer order package.  Select the menu option File > Define > 
Database, to open the Define Database dialog box, shown in Figure 8.

Click the Fields tab, if it is not selected at the top of the Define Database dialog box, to view a list of 
fields in the Sales Orders table. Type the name of the new field, called Shipping Tracking No, into the 
Field Name box, choose Text for the Field type, and click the Create button, to add the new field to the 
Sales Orders table.  Click OK to close the dialog box and return to the layout.
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Figure 8:  The Define Database dialog box for the bps_Sales_Orders file

If your FileMaker Preferences has been left with the default settings, the new Shipping Tracking No field 
will have automatically been added to the layout beneath the Ship Via field, as shown in Figure 9.

Figure 9:  The Shipping Tracking No field added to the Sales Order form view layout

You can switch the ‘Add newly defined fields to current layout’ FileMaker preference off, by selecting 
the menu option Edit > Preferences, selecting the Layout tab, and clearing the check box shown in 
Figure 10.
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Figure 10:  The Preferences dialog box Layout tab

If the newly defined field called Shipping Tracking No has not been automatically added to the 
layout, you can add the field by dragging the Field tool, in the Status Area, to the required position 
and selecting the new field from the Specify Field dialog box, that appears when the mouse button is 
released.

You can use the new Shipping Tracking No field to record the unique shipping reference that your 
supplier may provide you with, when your order is shipped.  We can use the contents of this field as 
part of a dynamic Web query using the Web Viewer Control in a new layout.

Step 4:  Adding a New Layout to Incorporate a Shipping Tracking Web Viewer

We can add a new blank layout to the Sales Order file, using the menu option Layouts > New Layout/
Report.   As an alternative, we can save time and preserve the same format and design for our new 
Web Viewer layout, by making a duplicate layout of the existing Form View layout and adding a new 
Web Viewer layout object to the duplicate layout.  With the Sales Order Form View layout open, switch 
to Layout Mode and choose the menu option Layouts > Duplicate Layout.

A new layout will appear on screen with exactly same appearance as the original Form View layout.  We 
need to give this layout a more descriptive title and remove all the field and field labels, to make room 
for the Web Viewer layout object..

Open the Layout Setup dialog box, by selecting the menu option Layouts > Layout Setup.  In the 
Layout Setup dialog box, shown in Figure 11, rename the layout Form View Shipping Tracking.  Click 
the OK button to return to the layout.
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Figure 11:  The Layout Setup dialog box

We want to preserve the same strip of buttons across the top of the layout, while removing the sales 
order fields.  Click and drag a rectangle across the layout that encompasses, and highlights, all the 
fields and field labels, as shown in Figure 12.  Click the backspace or delete keys to remove the 
highlighted layout objects.  This should leave you with a layout which is blank below the horizontal red 
line.

Figure 12:  Highlighting all the layout objects below the strip of buttons in the new Form View Shipping 
Tracking, ready for deletion
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The new Web Viewer tool can be found in the Status Area between the Tab Panel and Button tools, 
shown by the cursor in Figure 13.

Figure 13:  The Web Viewer tool in the Status Area (left) and the Web Viewer Insert menu option (right)

Click the Web Viewer tool and drag the crosshair to draw a new Web Viewer on the Form View 
Shipping Tracking layout.  When you have drawn the outline rectangle for the Web Viewer and 
released the mouse button, the Web Viewer Setup dialog box will then appear, as shown in Figure 14.

To get started with using the Web Viewer to track shipping, select the FedEx Web site from the list.  You 
will notice that a Tracking Number box appears in the upper right of the dialog box, with a right arrow 
button.  As displayed in Figure 14, click the button and select the Specify Field button to insert the 
Shipping Tracking No field from the Sales Order table.

Figure 14:  The Web Viewer Setup dialog box
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You can see that the Web address at the base of the dialog box now incorporates our Shipping 
Tracking No field, as part of the URL.  When a valid FedEx tracking number is typed into the Shipping 
Tracking No field, the Web Viewer should now have enough information to display the online shipping 
status of our package. 

It is a good idea to add the Shipping Tracking No field to our new layout.  Use the Field tool to add 
the field onto the layout and select it from the Specify Field dialog box list, above the Web Viewer, as 
shown in Figure 15.

Figure 15:  The Web Viewer and Shipping Tracking No field added to the new Layout

You can now switch to Browse Mode, and type in a sample FedEx tracking number, to test if the Web 
Viewer is working, as shown in Figure 16.
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Figure 16:  The Web Viewer displays the current live status of a shipment based on the value in the 
Shipping Tracking No field

Step 5:  Adding Navigation Buttons to switch between the Form View and Shipping Tracking Layouts

You have now successfully added a Web Viewer to your Sales Order file to track the shipping status of 
your orders.  It is likely that will want to frequently switch between the Sales Order Form View, List View 
and the Shipping Tracking layouts.  The easiest way to manage this is to add a new button to open the 
Shipping Tracking layout.

With the Sales Order layout open, switch to Layout mode and highlight the Go to List Layout button.  
Choose the menu option Edit > Duplicate to create another button and use the arrow keyboard keys 
to move it to the side of the other two buttons, as shown in Figure 17.

 Figure 17:  Duplicating an existing button to open the Shipping Tracking layout

With the new button highlighted, select the menu option Arrange > Ungroup.  You can then highlight 
and remove the list icon from the new button.  You can now select the Text tool from the Status Area, 
to add a descriptive label to the button.  You might like to give the button a different fill color and use 
the menu option Arrange > Send Backward to place the button behind the horizontal red line.  The 
completed new button is shown in Figure 18.
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Figure 18:  Adding a new navigation button to open the Shipping Tracking Layout

Step 6:  Adding a Navigation Script for the Button

The new button when clicked on, should switch to the Shipping Tracking layout.  We need to add a new 
script to the file to do this.  We can base this on an existing navigation script.  Open the Define Scripts 
dialog box, by selecting the menu option Scripts > ScriptMaker.  Highlight the script called Go To List 
Layout in the list of scripts and click the Duplicate button.  A new script called Go to List Layout Copy 
will appear as the next script in the list.  Highlight this script and click the Edit button, to open the Edit 
Script dialog box.  The new script can be renamed Go to Shipping Tracking Layout.   In the script, the 
Go to Layout script step can be highlighted and modified, using the Specify drop-down list in the Script 
Step Options section, to select the layout called Form View Shipping Tracking, as shown in Figure 19.

Figure 19:  The new Go to Shipping Tracking Layout script

Click the OK button to close first the Edit Script and then the Define Scripts dialog boxes.

We can now make our new navigation button run the new script, when clicked. Double click on the 
View Tracking button, to open the Button Setup dialog box.  Select the Perform Script command and 
click the Specify button in the Options box to open the Specify Script Options dialog box.  Select the 
Go to Shipping Tracking Layout script, as shown in Figure 20.
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Figure 20:  Using the Button Setup dialog box to make the View Tracking button run the Go to Shipping 
Tracking Layout script

We based the new Shipping Tracking layout on the Form View Sales Order.  To create a consistent set 
of navigation buttons, we should also make sure that the red Form View button also returns to the Sales 
Order layout, when clicked.  Click the left hand red button, to highlight it, and select the menu option 
Format > Button Setup.  Highlight the Perform Script button command and select the Go to Form 
Layout script, as shown in Figure 21.
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Figure 21:  Assigning a script to the Form View Button to return to the Form View Layout

Step 7:  Customizing the Web Viewer for Other Online Shipment Tracking Providers

The shipping tracking Web Viewer that we built in the previous section made use of the FedEx Web 
site, which is already available in the Web Viewer Setup dialog box.  It is easy to adapt a Web Viewer for 
your own preferred shipping company, if they already offer an online tracking service.

As an example, we can adapt a Web Viewer to make use of the DHL Web site that includes a customer 
shipment tracking field.  You can investigate how the shipping company’s Web site formats a shipment 
tracking query.  Type a valid shipment number into the Web page field and click the Track button.  
Copy the resulting URL that appears in your browser address box to the clipboard.

Add a new Web Viewer to your FileMaker layout.  In the Web Viewer Setup dialog box, select the 
Custom Web Address at the top of the Web site list.  Click the Specify button to the right of the Web 
address box and paste the copied URL address.  As shown in Figure 21, you will need to adapt the 
pasted URL for the shipping company, so that it is wrapped within leading and trailing quotation marks.  
You will also need to substitute the shipping number string in the URL for the Shipping Tracking No 
field from the Sales Order table.
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Figure 22:  A customized Web Viewer address for the DHL online shipment tracking service

You can test your new Web Viewer by switching to Browse mode and typing in a valid DHL number into 
the Shipping Tracking No field, as shown in Figure 23.
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Figure 23:  The Web Viewer adapted for the DHL online shipping tracking service

Step 8:  Taking the Web Viewer Further

You are unlikely to want to create a whole set of Web Viewer layouts in your FileMaker Sales Order file, 
to manage all of the shipping companies that your business may use.  A better way to manage things 
is to create a single Web Viewer that is able to change the format of the Web address, depending on 
which shipping company is identified in the Ship Via field for an individual record.

In Figure 23, the Web address for a Web Viewer has been customized to be the result of a calculation 
formula, using the Specify button to open the Specify Calculation dialog box.  A case function has been 
used to test whether the contents of the Ship Via field in a record is FedEx or not.  If the Ship Via field 
contents is “FedEx”, the formula result will return the first Web address.  For all other Ship Via values, the 
Web Viewer will display the results of the second Web address; in this case using the DHL .  The case 
formula could of course be extended for other shipping company names.



How to Manage Shipping with FileMaker Pro page 22

Figure 24:  Complex calculations can be specified to determine the website displayed in a Web Viewer

Creating Mailing Labels With FileMaker

Step 1:  Adding a New Shipping Label Layout to a FileMaker File

You can easily add a mailing label layout to a FileMaker contact management or sales order file.  
FileMaker has a built in New Layout / Report Assistant.  If you choose to create a new label layout, you 
will find a list of standard Avery labels are already available in FileMaker, or you can customize the size 
and format of a new label layout for your specific requirements.

The Sales Order file, which forms part of the Business Productivity Solution, includes an existing mailing 
label.  The Address Label button can be found just above the Status field in the Form View sales Order 
layout.  When clicked, the Address Label button has been preset to run a script that opens a new 
window and displays an Avery 5164 label. If your company prefers to use a different label size, it is easy 
to add additional label layouts to the file.

With the Sales Order file open, switch to Layout mode and select the menu option Layouts > New 
Layout/Report.  The New Layout/Report dialog box will appear on screen as shown in Figure 25.  
Select the Labels layout type from the list.  In this example we are going to create a large shipping label 
using the Avery 8168 address labels, which prints two large labels to a page.  Type in a suitable title in 
the Layout Name box and click the Next button.
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Figure 25:  The New Layout/Report dialog box

The New Layout/Report dialog box then enables you to choose a label measurement using the built in 
range of Avery labels, or click the button to create a custom label.  With a custom label, you can set the 
number of labels across the page, the width and height of each label.  If your settings will not fit on the 
printed page, FileMaker will prompt you with a message and advise you to change your settings. The 
specify labels dialog box is shown in Figure 26.
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Figure 26:  The Specify Label Layout dialog box

Click the Next button and the New Layout/Report dialog box then enables you to specify what fields 
you would like to include in the label layout, as shown in Figure 27.  The selected fields are added to 
the new label layout as merge fields in a text block.  This makes the printed label easier to read and 
ensures an even text flow.

Figure 27:  The Specify Label Contents dialog box
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The FileMaker layout assistant now has enough information to create the new label layout.  When you 
click the Next button you are presented with the choice of viewing the new label layout in Preview 
mode, which will give you an impression of how the printed label will look, or Layout mode, if you want 
to add additional text or a company logo to the label.  Click the view in Layout mode radio button, as 
shown in Figure 28, to open the new shipping label in Layout mode.
 

Figure 28:  The new label layout is now ready to view in Preview or Layout mode
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Our new Box Label layout is shown in Figure 29.

Figure 29:  The completed new Box Label 8168 layout

Step 2:  Adding a Navigation Button and Script for the New Label Layout

While we could use the Layout Menu in the Status Area to select our new shipping label layout, we 
could make it easier for colleagues to navigate through the Sales Order file, by using a new navigation 
script linked to a button, to open the label layout.

Open the Form View layout, using the Layout menu in the Status Area.  While still in Layout mode, 
highlight the Address Label button, which is just above the Status field.  Select the menu option Edit 
> Duplicate to make a copy of the button.  Use the arrow keyboard keys to move the copied button to 
the right and  in line with the Packing Slip button.  Now select the Text tool in the Status Area, and click 
the copied button.  You can now rename the button to Box Label, as shown in Figure 30.

Figure 30:  Adding a Box Label navigation button to the Sales Order Form View layout
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We can copy and adapt an existing navigation script to select the correct label layout, when the Box 
Label button is clicked.  Open the Define Scripts dialog box by selecting the menu option Scripts > 
ScriptMaker.  Highlight the existing script called Address Label, Avery 5164 in the list, as shown in 
Figure 31 and click the Duplicate button.  A highlighted copy of the script will now appear below it in 
the list.

Figure 31:  Duplicating an existing script for the new label layout

Click the Edit button while the copied script is still highlighted, to open the Edit Script dialog button.  
Rename the duplicated script with the name of our new label in the title.

We only need to modify one script step in order to make the script open our new label, when run.  
Double click on the Go to Related Record script step to open the Go to Related Record options dialog 
box, shown in Figure 32.  Use the down arrow to select our new Box Label Avery 8168 layout from the 
drop-down list in the Show record using layout box.  Leave the other option settings as before and click 
the OK button.  
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Figure 32:  Modifying the new script to open the new label layout

Click the OK button in all three dialog boxes to return to the layout.  Now double click the Box Label 
button to open the Button Setup dialog box.  The Perform Script button command should already be 
highlighted.  Click the Specify button, to open the Specify Script Options dialog box and select the 
new script in the list, as shown in Figure 33. 
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Figure 33:  Modifying the Box Label button to perform the Address Label, Avery 8168 script,  
when clicked

Creating Barcodes with a FileMaker Plug-In

Step 1:  Adding a Barcode to your Mailing Address Labels

There are several third party FileMaker plug-ins available that enable you to generate and print a 
barcode from FileMaker.  You might like to include a barcode on your shipping note to assist staff in 
recording goods received in and dispatched out.  If you add a barcode to your mailing address or 
shipping labels, you may be able to negotiate a reduced shipping fee with your postal service provider.

Further details on barcode plug-in providers and developers who specialize in shipping solutions can 
be found at the end of this article.  We can use the barcode plug-in available from the Peninsula Group 
to demonstrate how easily a shipping barcode can be added to an address label.

You can request a range of standard mailing service barcodes when you purchase the FileMaker 
Barcode plug-in from The Peninsula Group.  In the USA, the Postal Service has developed the PostNet 
(Postal Numeric encoding technique) barcode to encode zip code information on letter mail for rapid 
and reliable sorting by barcode sorters (BCSs).  Similar barcode systems exist with the Royal Mail in the 
UK and the Australian Postal Service.

In this example we will add a PostNet barcode to our address labels.

Step 2:  Installing the FileMaker Barcode Plug-In

On a Windows PC, copy the Barcode plug-in to the folder called Extensions within the FileMaker Pro 
8.5 folder, shown in Figure 34.
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Figure 34:  The Barcode plug-in in the FileMaker Extensions folder

The Barcode plug-in software includes a Barcode font and an optional Postcode font, which is used to 
generate some barcodes.  These fonts must be copied to the Fonts folder within the Windows folder.

Launch FileMaker Pro and select the menu option Edit > Preferences to open the Preferences dialog 
box.  Select the Plug-Ins tab.  Highlight and check the Barcode plug-in in the list, as shown in Figure 35, 
and make sure that the plug-in has a tick in the enabled box.
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Figure 35:  Enabling the Barcode plug-in in the Preferences dialog box

Step 3:  Creating a PostNet Barcode Calculation Field

Open the Sales Order file and select the menu option File > Define Database.  We are going to create 
a new calculation field called Ship to Postal Code PostNet Barcode.  Type the field name into the box 
and select Calculation from the field type drop-down list, then click the Create button.

The Specify Calculation dialog box will then appear, as shown in Figure 36  Select the External 
Function menu from the drop-down list.  Within the Barcode set of functions, double click the Barcode-
Postnet function to copy it into the calculation formula.  Overwrite the parameter text with the formula 
displayed in Figure 36. The numbers in the barcode formula after the Ship to Postal Code field, refer 
to the height of the barcode in millimeters, the barcode scale in percent, The bar width reduction in 
microns to allow for ink spread (normally set to 0) and whether there are numbers underneath the 
barcode or not (0 for no numbers, 1 for numbers).  The calculation result is set to text.  Click the OK 
button to submit the formula.
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Figure 36:  The new Barcode-Postnet calculation field formula

We can now add the new barcode font to our shipping label layout.  Most country postal services insist 
that the barcode is set on the lowest line of the address.  The USPS recommends that a minimum font 
size of 12 is used when printing PostNet barcodes.

Switch to Layout mode and open one of the two label layouts that now exist in the Sales Orders file.  
Add the new barcode field as the last line in the address text block.  Select the Text tool in the Status 
Area and click the end of the text block. Add a new line to the text block and open the Specify Field 
dialog box by selecting the Insert > Merge Field menu option.  Select the new Ship To Postal Code 
PostNet Barcode field from the list and click the OK button.

The new field should now appear at the base of the address text as shown in Figure 37.  To ensure that 
the barcode prints correctly, we need to change the field font to Barcode and the font size to 12 pt.  
Highlight the field and use the mouse menu to select the Font and Size menu options.  You can also 
use the Format > Text menu option, to open the Text Format dialog box.
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Figure 37:  Modifying the barcode merge field to display using the Postcode font

You can now switch to Browse or Preview mode, to check that the PostNet barcode is displayed 
correctly, as shown in Figure 38.

Figure 38:  The shipping address with the PostNet barcode displayed
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FileMaker Barcode and Shipping Solution Resources

A barcode FileMaker plug-in is available from the following vendors:

Peninsula Software
www.peninsula-group.com/FMbar/Default.html

ID Automation
www.idautomation.com/fonts/tools/filemaker

As an alternative to installing and configuring a third party plug-in, Brian Dunning at Venture 
Consulting has developed a FileMaker barcode solution that can be integrated with your existing 
database and ships with several of the most common barcodes used for shipping and address 
management.
www.briandunning.com/bar-code

NRG software is a long established FileMaker development firm that offers a range of shipping 
software solutions for FileMaker.
www.nrgsoft.com

For more helpful guides and resources, please visit www.filemakeroffer.com/DIY 
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